Current Organizations / Institutes

The organizations/institutes from the scholar's latest article

Previous Organizations / Institutes

The organizations / institutes from the scholar's other articles in the past ten years


Laurent Toutain has a total of 16 co-authors. Here are the top co-authors by number of shared publications:


Latest Publications

  • Application Layer Protocols

    by Laurent Toutain, Omar Elloumi, Steve Liang, Hylke van der Schaaf, Bart De Lathouwer, Ana Minaburo, David Raggett


  • Open Access

    Yet Another Compact Time Series Data Representation Using CBOR Templates (YACTS)

    by Sebastian Molina Araque, Ivan Martinez, Georgios Z. Papadopoulos, Nicolas Montavont, Laurent Toutain

    The Internet of Things (IoT) technology is growing rapidly, while the IoT devices are being deployed massively. However, interoperability with information systems remains a major challenge for this accelerated device deployment. Furthermore, most of the time, IoT information is presented as Time Series (TS), and while the majority of the studies in the literature focus on the prediction, compression, or processing of TS, no standardized representation format has emerged. Moreover, apart from interoperability, IoT networks contain multiple constrained devices which are designed with limitations, e.g., processing power, memory, or battery life. Therefore, in order to reduce the interoperability challenges and increase the lifetime of IoT devices, this article introduces a new format for TS based on CBOR. The format exploits the compactness of CBOR by leveraging delta values to represent measurements, employing tags to represent variables, and utilizing templates to convert the TS data representation into the appropriate format for the cloud-based application. Moreover, we introduce a new refined and structured metadata to represent additional information for the measurements, then we provide a Concise Data Definition Language (CDDL) code to validate the CBOR structures against our proposal, and finally, we present a detailed performance evaluation to validate the adaptability and the extensibility of our approach. Our performance evaluation results show that the actual data sent by IoT devices can be reduced by between 88% and 94% compared to JavaScript Object Notation (JSON), between 82% and 91% compared to Concise Binary Object Representation (CBOR) and ASN.1, and between 60% and 88% compared to Protocol buffers. At the same time, it can reduce Time-on-Air by between 84% and 94% when a Low Power Wide Area Networks (LPWAN) technology such as LoRaWAN is employed, leading to a 12-fold increase in battery life compared to CBOR format or between a 9-fold and 16-fold increase when compared to Protocol buffers and ASN.1, respectively. In addition, the proposed metadata represent an additional 0.5% of the overall data transmitted in cases where networks such as LPWAN or Wi-Fi are employed. Finally, the proposed template and data format provide a compact representation of TS that can significantly reduce the amount of data transmitted containing the same information, extend the battery life of IoT devices, and improve their lifetime. Moreover, the results show that the proposed approach is effective for different data types and it can be integrated seamlessly into existing IoT systems.


  • Performance Analysis and Optimal Tuning of IETF LPWAN SCHC ACK-on-Error Mode

    by Sergio Aguilar, Patrick Maille, Laurent Toutain, Carles Gomez, Rafael Vidal, Nicolas Montavont, Georgios Z. Papadopoulos

    The Internet Engineering Task Force (IETF) Low Power Wide Area Network (LPWAN) Working Group has developed the Static Context Header Compression (SCHC) framework to enable IPv6 over LPWAN. In order to support 1280-byte packets, as required for IPv6, SCHC includes a fragmentation functionality, since relevant LPWAN technologies offer very short data unit sizes and do not provide native fragmentation mechanisms. SCHC offers 3 fragmentation modes: No-ACK, ACK-Always, and ACK-on-Error, the latter being especially promising due to its reliability and high efficiency. In this article, we develop a mathematical model to compute the most critical performance parameters for the SCHC ACK-on-Error mode, namely, the acknowledgment traffic incurred by a fragment receiver for the successful delivery of a fragmented packet. The model is used to evaluate the SCHC ACK-on-Error mode performance, as well as to optimally tune its main parameters when used over LoRaWAN and Sigfox, for different packet sizes. Additionally, we illustrate how our derived optimal settings allow to reduce the acknowledgment traffic in a number of scenarios.


  • Open Access

    IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Routing Header

    by C. Bormann, L. Toutain, R. Cragie

    This specification introduces a new IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) dispatch type for use in 6LoWPAN route-over topologies, which initially covers the needs of Routing Protocol for Low-Power and Lossy Networks (RPL) data packet compression (RFC 6550). Using this dispatch type, this specification defines a method to compress the RPL Option (RFC 6553) information and Routing Header type 3 (RFC 6554), an efficient IP-in-IP technique, and is extensible for more applications.